Move to API that is not deprecated.