One more try, with the right dependencies this time...