Moved to Servlet 2.2 spec jar for compatibility with tomcat 3.3 .