Don't pull in two versions of bouncycastle
[java-idp.git] / src / main / assembly / bin.xml
index 59ab2e4..0f502d2 100644 (file)
@@ -14,6 +14,7 @@
                 <exclude>org.apache.xalan:*</exclude>
                 <exclude>org.apache.ant:*</exclude>
                 <exclude>ant-contrib:*</exclude>
+                <exclude>edu.internet2.middleware:ant-extensions:*</exclude>
             </excludes>
             <includes>
                 <include>*:jar:*</include>
@@ -24,6 +25,7 @@
             <includes>
                 <include>org.apache.ant:*</include>
                 <include>ant-contrib:*</include>
+                <include>edu.internet2.middleware:ant-extensions:*</include>
             </includes>
         </dependencySet>
         <dependencySet>
@@ -35,7 +37,7 @@
         </dependencySet>
     </dependencySets>
     
-    <fileSets>
+    <fileSets>    
         <!-- Copy up our installer srcipts into the root of the package -->
         <fileSet>
             <directory>src/installer/bash</directory>
@@ -43,6 +45,8 @@
             <includes>
                 <include>*.sh</include>
             </includes>
+            <fileMode>0755</fileMode>
+            <directoryMode>0755</directoryMode>
         </fileSet>
         <fileSet>
             <directory>src/installer/bat</directory>
             <directory>src/main/webapp</directory>
             <outputDirectory>/src/main/webapp</outputDirectory>
         </fileSet>
+        <fileSet>
+            <directory>src/tools</directory>
+            <outputDirectory>src/tools</outputDirectory>
+        </fileSet>
         
-        <!-- Docs -->
+        <!-- Documentation -->
         <fileSet>
             <includes>
                 <include>RELEASE-NOTES*</include>
                 <include>LICENSE*</include>
             </includes>
         </fileSet>
-
-        <!-- Documentation -->
         <fileSet>
             <directory>doc/</directory>
             <outputDirectory>/doc</outputDirectory>